comp mode error

V+ discussions, tips and tricks, sample code, Q & A

comp mode error

Postby ejraleig » Tue Sep 19, 2017 11:26 am

Hi,

I am trying to develop an application that uses the pendant to teach the robot a start position and then I want to execute a vplus program from that start position. The issue i'm having is that every time I switch from pendant control to the vplus code, i need to hit the power on button on the pendant to put the system into 'comp mode'. Is there a way to switch to 'comp mode' in code? This is a problem for me because i am teaching the robot many locations (many repetitions) in a row so there is a lot of manual button pressing.

- Eddie
ejraleig
 
Posts: 1
Joined: Tue Mar 06, 2012 3:39 pm

Re: comp mode error

Postby Guenter Grass » Wed Sep 20, 2017 2:56 am

Hi eddie,

please let us know which hardware and software you are using. E.g.
Hardware
SmartController CX
T2 Pendant
Cobra s600
etc.

Software
V+ 17.2 C3

Especially the programming of the pendant has changed a lot from the SmartController CX to the new SmartController EX.

Nevertheless if you are using a hardware pendant like the T2 or T20 you can switch directly into COMP mode on the pendant. On the T2 pendant you can press the COMP/PWR button on the T20 pendant you press Jog Mode until COMP mode is displayed on the left side of the pendant screen. If you use the software jog control in ACE you can just use the mouse to click on COMP mode.

When teaching do you switch the key on the front panel to manual? And after teaching you switch it back to automatic?

Sometimes a code snippet can help to understand what you are exactly trying to do?

Best Regards
Günter
Guenter Grass
 
Posts: 189
Joined: Thu Oct 16, 2008 4:34 am


Return to V+

Who is online

Users browsing this forum: No registered users and 1 guest