trouble with Viper S650.

trouble with Viper S650.

Postby Ottavio » Mon Dec 29, 2008 6:16 pm

Robot: Viper s650
Controller: CX
Servo Drive Unit: MB-60R

I´m currently integrating a Viper s650 for a simple pick and place machine tending operation, and the process has been something like a nightmare. Maybe one month and a half ago, while comissioning the system, we had a fatal failure in the system, all six encoders were bad, and also had an RSC failure (initial message). The cause? Well, we left the robot (only the mechanical unit) in the laboratory on Friday night, in order to put it to work again on Monday morning, leaving the controller and electrical cabinet on application site. When we had the failure, we found that the firewire cables were plugged wrongly on the CX (like somebody removed from port 1.1 and put it on 1.2), but also finding the ports somehow damaged and deformed, almost like somebody tried to plug it in the wrong way and then powered on the system. We found also that one of the firewire ports on the MB-60R unit was damaged. I really don´t know if this type of "sabotage" could produce this type of damage, but the thing is that the system was working perfectly when we left it. Judge by yourselves.

First we tried to fix the RSC problem by using the rsc_set, and RSC_RSTR restore programs, with poor results, after that, we tried to use the original RSC file to commit to the robot, without any results. After that, Adept sent us a new RSC card to change the currently installed, and the result was the same. On the RSC management programs, we had always that the system could not verify the encoders, hardware status code: 22. We could not commit any data into the RSC, and also we had encoder failure -1025 on the Adept Desktop screen.

We checked the encoder power supply system, and everything was ok (using also the Denso Manual). Just to make the story short, we tried every possible way to troubleshoot the system, but the result were always E0 up to E6, RC on our MB-60R unit. On the other side, AS explained before, this unit had also one of the firewire (1.1) ports damaged, since we could not even find the network when we wrote SRV.N on the terminal. In order to find the network we needed to plug the cable to the 1.2 connector. Anyway, finally, suspecting that maybe the MB60R unit was the problem (since we had normal readings on the voltages of the encoder power supply, and also the voltage supply to the RSC), Adept sent us a new MB60R unit. When we installed, it immediatly recognized the RSC and hardware settings, and proceed to perform full data commit into the robot, by using our original RSC file. We finally made to load all the configurations, and even if we received some strange messages warning that some data could not still be committed to robot, the data finally got into the system. We checked the current values and parameters, and eveything seems to be correct. The system promptly responded with a OK message, and then, after a calibration, we had our ON status. When we power up the unit, in a very short burst, a message of E0 appears on the MB-60R unit, and then disappears, leaving place to the OK message.

The robot is capable of moving without any problem, running programs and all, but after a while we are experiencing a heavy vibration on the servo motors, seeming almost like a tuning issue. We removed the gripper in order to exclude overweight or the effect of inertia, but it didn´t change much, after a while the system starts to vibrate heavily, specially on axis N°3. If we issue a power down on the servos, and then power on again, the systems behaves normally, and after a while vibration starts again. Is there a way we can troubleshoot this vibration and noise? While in this state, the system usually does not issue an alarm (we had only once a D3 alarm, a duty cycle alarm for joint3, on a very low speed, maybe due to heavy vibration), and we can run programs, and also jog the robot with the vibration on. Is there a way that maybe some servo parameters can be adjusted to eliminate this problem?? Do we need to perform any more calibrations beside the one we did on the system restore?? Could it be the surface in which we mounted the system, maybe resonating at some point with the robot structure? If anyone has experienced something like this before, please advice,
Posts: 1
Joined: Mon Dec 29, 2008 5:28 pm

Re: trouble with Viper S650.

Postby PeterL » Fri Jan 02, 2009 3:23 pm


it sounds you have a hardware problem on your system.

The mounting of the robot can cause this vibration but I don't think this is really the problem you have. D3 (Duty cycle exceeded Mtr.3) means that to much current was applied to this motor over a long time. So it seems something is blocking the motor. This can be the brake inside the motor. If the brake doesn't release properly it will block the motor.

To check the brake, please use the brake release box and move joint 3 by hand. Compare the movement with some other axis. Can you feel that Joint 3 is different from the other joints?

Best Regards,

Posts: 8
Joined: Wed Oct 15, 2008 2:48 am

Return to Viper s650/s850

Who is online

Users browsing this forum: No registered users and 1 guest