CS7B Axe amplifier

Moderator: MikeM

CS7B Axe amplifier

Postby Karl » Fri Jun 06, 2014 5:49 am

Hi everyone,

We recently bought two used staubli RX90 robots with CS7B controllers. But one of them just lost the ability to calibrate and enable power. I have found that the problem probably is located in the Axe 2 amplifier. At startup the seven segment display of the remaining axis displays "1". But the Axe 2 displays flashes the following errors: "e101 e102 e103 e104" ending with all all segments constantly on.
The CS7B controller manual describes this behavior as "Hardware load failures". I have tried to remove the Axe 2 amplifier but is unable to find any obvious problems on the board. Swapping amplifier 1 and 2 makes the problem follow the amplifier.

The obvious but pricey solusion would be to buy a new Axe amplifier. But i wanted to hear if anyone has encountered a similar problem and solved it in a better way. I'm hoping that the Axe amplifier might be okay but is needing a reset or something.

I'm an electronics ingineer but industrial robotics is new to me. I hope that somebody is able to help me out.

// Karl
Posts: 1
Joined: Tue May 06, 2014 10:38 am

Return to MV Controls

Who is online

Users browsing this forum: No registered users and 1 guest