Latch buffer setting on EX Controller

Information and discussion regarding the ACE PackXpert software

Latch buffer setting on EX Controller

Postby duncan » Wed Oct 07, 2015 4:23 pm

I have previously had to increase the latch buffer setting to allow for more than one camera on a single belt.
On the EX controller, I can no longer find this setting.
Does it still exist, and how do I change it?

The problem is the following:
When running ACE, I am getting multiple latch triggers followed by missing latch triggers.
If remove the second latch signal completely, the fault goes away.

Any advice gratefully received.

Thanks!
Duncan
duncan
 
Posts: 11
Joined: Mon Jun 09, 2014 6:11 pm

Re: Latch buffer setting on EX Controller

Postby Uwe_S » Fri Oct 09, 2015 6:26 am

Hello Duncan,

you will need to tell your belt to be latched by several camera trigger signals.
I assume that each of your cameras sends a different trigger signal to the EX-controllers fast input (e.g. 1001 and 1002).
If you don't do this, the belt is only latched by the one and only initial signal for your first camera. If PackXpert takes a picture with the new second camera it expects a latched belt encoder value triggered by the second digital input. As the belt is not assigned to be latched by that signal PackXpert will not get that information and replies with 'missing latch trigger'.
Please go to the 'Configure Encoder Latches' menue in ACE via:
- doubleclick on your controller object in the ACE workspace
- click on the 'Configure' button
- choose 'configure encoder latches' and click the 'Next' button

You will see table like this:
Encoder Channel Position Velocity Latch Signals
Encoder 1 0 0 1001

Click behind the 1001 (or whatever signal triggers your first camera) and add your second camera trigger signal (seperated via a comma like '1001, 1002').
'Save' that setting and try your PackXpert application again.
Hope this works,
Uwe
Uwe_S
 
Posts: 1
Joined: Tue Oct 14, 2008 11:31 pm


Return to ACE PackXpert

Who is online

Users browsing this forum: No registered users and 1 guest