Help! MobilePlanner and MobileEyes steal focus in Windows 7!

Commercially-available robots from Adept MobileRobots

Help! MobilePlanner and MobileEyes steal focus in Windows 7!

Postby ToddR » Fri Feb 01, 2013 2:10 pm

When I am running MobilePlanner or MobileEyes in Windows 7 and I make a configuration change, for example, even if I'm working on another program--say, writing and email--the focus is switched to Mobile software to show a popup message, or other alert. This is pretty annoying. Is there anything I can do to make this stop??!

Re: Help! MobilePlanner and MobileEyes steal focus in Window

Postby ToddR » Fri Feb 01, 2013 2:14 pm

Thanks, ToddR, I have had that problem too--let me tell you how I was able to fix it.

You can follow the directions here:

I have copied them to this post--

    Click on Start and then Run.

    In the text box in the Run window, type regedit and click OK. This will open the Registry Editor program.

    Locate the HKEY_CURRENT_USER folder under My Computer and click on the (+) sign next the folder name to expand the folder.

    Continue to expand folders until you reach the HKEY_CURRENT_USER\Control Panel registry key.

    Select the Desktop key under Control Panel.

    On the right-hand side of the screen, locate and double-click on the ForegroundLockTimeout DWORD.

    In the Edit DWORD Value window that appears, set the Value data: field to 30d40.

    Note: Make sure the Base option is set to Hexadecimal when entering the DWORD value.

    Click OK and then close Registry Editor.

    Reboot your PC for the changes you made to take effect.

    From this point forward, programs should no longer steal the focus from the window that you're currently working in.

ForegroundLockTimeout.PNG (145.06 KiB) Viewed 16352 times

Re: Help! MobilePlanner and MobileEyes steal focus in Window

Postby ToddR » Fri Feb 01, 2013 2:15 pm

Hey, thanks ToddR, that was helpful, but after I reboot I still have the problem!

I went to the registry editor and noticed that the value I set for ForegroundLockTimout had been set back to zero!

Re: Help! MobilePlanner and MobileEyes steal focus in Window

Postby ToddR » Fri Feb 01, 2013 2:46 pm

I was afraid you'd say that, I ran into the same issue. For most people simply changing that one value would eliminate the problem all together, but for you the problem is most likely that there is a program on your computer which starts itself at system startup that sets this value to 0. This is probably the source of your focus-stealing woes.

Here is how I was able to figure out what program was setting this value behind my back:

First, I downloaded a program called "procmon" from Microsoft. You can find it here:

download and install procmon as administrator, then open it.

go to the Filter menu, and select "Filter..."

Create a new filter exactly as shown in the image below, and then click [Add].

set up filter.PNG
set up filter.PNG (141.94 KiB) Viewed 16351 times

What procmon is doing is monitoring system events, and displaying them all. We've just told it not to show us anything that isn't related to ForegroundLockTimeout (the focus stealing parameter).

You might notice some events show up in the main window, but we're specifically looking for ones that have the word "Set..." in the "Operation" field. The example below shows some events, but none of them say Set.

events.PNG (79.09 KiB) Viewed 16351 times

If your situation is like mine, then the problem where ForegroundLockTimeout is being changed is not occurring during normal operation, but instead, at startup. There is a way to make procmon keep a startup log so you can check this. From the Options toolbar, check the option for Enable Boot Logging. In the resulting popup, just click OK - don't worry about checking the box for "Generate Profiling Events."

enable boot logging.png
enable boot logging.png (74.54 KiB) Viewed 16351 times

Then restart your machine.

When your computer starts back up, log in and open procmon again. It should tell you that there was a log taken at startup and ask if you want to saveit. Click yes, and choose a place to save the file.

startup.PNG (26.16 KiB) Viewed 16348 times

The next part could take a while, be patient:

waiting.PNG (8.85 KiB) Viewed 16348 times

After the processing is complete you'll see many items in the main window of procmon. We are looking for one which says "RegSetValue" in the "Operation" column.

the culprit.PNG
the culprit.PNG (248.21 KiB) Viewed 16348 times

I found that the culprit on my machine which was setting the "focus stealing parameter" was NetGear Genie. I know I don't need that program, so I uninstalled it, then set the registry key again, as described in my post above, and rebooted. This solved the issue!

If you know you can remove the program, go right ahead, otherwise, check to see if there is an option available from that program to not make this change.

Thanks for bearing with me to get through this issue - ToddR

Return to Adept Mobile Robots

Who is online

Users browsing this forum: No registered users and 2 guests